publishing tagged posts

SP2013 PageNotFoundError.aspx returns still a 200 code…not good

Category: #SharePointSharePoint 2013 Comments: No comments

In SharePoint 2013, if you create a Publishing Web Portal you will find – directly in the Pages library of your root web – a PageNotFoundError.aspx page.

It is good to have such a page already created and working if you type any not existing page…In any case, if you work in a real intranet web site, pay attention that the page is still returning a 200 http code and this is – in terms of SEO – very poor.

As it is shown in the image below the return code is not the right one:

Read More

Unfair behavior of PublishingLayoutPage OnPreInit event in SharePoint 2010

Category: #SharePoint Comments: No comments

I really like SharePoint; there are things that other CMS are not able to do and it can be useful both on Intranet  and Internet environment, but sometime it does really bad thing…and – trust me – really really bad.

With my colleague Leon we are developing a publishing site with SharePoint 2010. We are using our own masterpage and we are setting our masterpage directly in the markup  setting explicitly the MasterPageFile. Till here everything is fine…During the debug of a page layout we were worried because it was really too slow and when we attached the debug we saw a lot of symbols not required (Excel, strange usercontrols…)

The curiosity becomes anger and with our friend ILSpy we discover what the image below shows… no matters if you set your masterpage in the markup…in the OnPre...

Read More