SharePoint 500 Error adding a link as icon with standard Editor

Category: #SharePoint Comments: No comments

We are working in a intranet for a client and during the UAT the client has raised a strange problem. trying to add a link in SharePoint with the OOB buttons, checking the option “display as icon” he got a JavaScript alert with a 500 Error. We thought that it could be a SharePoint problem but then taking a look to the system log we found that the problem was different. The solution has been found by my colleague Nicolas Meistretty¬†and below where to change the settings.

If you application – as was our case – doesn’t use a Kerberos authentication the Extended Protection of the IIS setting Windows Authentication must be set to OFF, otherwise the client.svc service will be not compatible with the one set in IIS.

This is what you will have in the eventviewer if the error appears.

 

Within the Authentication IIS open the advanced settings and change the parameter to OFF.

 

Without this change the SharePoint application will behave quite strangely: the DISPLAY as ICON won’t work and the EMAIL as LINK will open your Outlook with the only text SAMPLE instead of the link of your page.

 

Thanks again to Nicolas, hope this helps,

 

Manuel

Tags:  , , ,

Leave a reply

*


7 + = fourteen

You may use these HTML tags and attributes: <a href="" title=""> <abbr title=""> <acronym title=""> <b> <blockquote cite=""> <cite> <code> <del datetime=""> <em> <i> <q cite=""> <strike> <strong>